Resolved
We have identified the root cause as upstream provider cluster maintenance that affected our service ingress. Some clients experienced connection errors, but subsequent retries were successful.
Resolved
We have mitigated the issue and continuing the root cause investigation.
Investigating
We are investigating some connection errors in US region.