Resolved
This incident has been resolved.
Identified
We are continuing to work on a fix for this issue.
Identified
Our file server is unable to verify read permissions. Most requests should succeed now.
Investigating
We're experiencing an elevated level of errors downloading files and are currently looking into the issue.